• Howdy! Welcome to our community of more than 130.000 members devoted to web hosting. This is a great place to get special offers from web hosts and post your own requests or ads. To start posting sign up here. Cheers! /Peo, FreeWebSpace.net
managed wordpress hosting

Linksys Router DHCP Renew not working


W as in Whisky
So i got this problem with my linksys router

the internet stopped working. on both the wired and wireless computers.
they could communicate with each other fine, but could not connect to the internet.

so I plugged the modem directly in the computer and it works just fine.
done a reset on the modem, and the router (twice with same results, once from the button on the back, one from within the web interface) and nothing. Still internet dosnt work.

Router status shows this:


Firmware Version: v2.02.7, Feb. 27, 2004
Current Time: Not Available
MAC Address: 00:0F:66:91:37:F0
Router Name: WRT54G
Host Name:
Domain Name:


Configuration Type
Login Type: Automatic Configuration - DHCP
IP Address:
Subnet Mask:
Default Gateway:
DNS 1:
DNS 2:
DNS 3:

clicking DHCP Release and DHCP Renew does not bring back an ip to the router. tried many times, stays at

ISP: Videotron Cable
Router: Linksys WRT54G
Modem: Motorola Surfboard SB5100

What could be the issue???
Last edited:
Try upgrading the firmware.

If that doesn't help, just set up static IP addresses on your boxes and forget about DHCP.
That happens alot with me. It's a problem with your modem. Just wait a day or call your provider. Be sure to reset your modem as well. I actually have the same hardware as you. Reset just the modem, then try to renew. If that doesn't work, reset just the router, then renew. If that doesn't work, reset them both at the same time.

Are you hard-wired into the router, or wirelessly connected?

Also, as Bruce said, be sure to updrage your firmware. That can be a real problem.

Firmware Version :   	v4.20.7, Aug. 18, 2005  	   	 
  	  	  	Current Time :  	Thu, 02 Feb 2006 20:59:54 	  	 
  	  	  	MAC Address :  	********	  	 
  	  	  	Router Name :  	WRT54G  	  	 
  	  	  	Host Name :  	  	  	 
  	  	  	Domain Name :  	hsd1.ga.comcast.net. 	  	 

	  	  	Login Type :  	Automatic Configuration - DHCP 	  	 
  	  	  	IP Address :  	******* 	  	 
  		  	Subnet Mask : 	  	
  		  	Default Gateway :  	********** 	  	
  	  	  	DNS 1 : 	  	 
  	  	  	DNS 2 : 	  	 
  	  	  	DNS 3 :  		  	 
  	  	  	MTU :  	1500
Last edited:
thanks brandon for hinting at this MAC address thing

had to enable mac address cloning, and then dhcp kicked in.
if I turn it off, it goes back to non-working mode. turn on, and it works.

i still dont fully understand the issue but oh well, it works :)
now lets try to reconfigure wireless on my own computer

tree, version 4.2 already, wow, im 2 full versions behind heh
btw, where do get an upgrade? looking at linksys`s site they have firmware
Firmware Date: 1/17/2006
Firmware Release Version: 1.00.6
thats not what im looking for is it?
Last edited:
You might have different id routers, the wrt54g comes in five versions:
You have to download the specific one for your router.
i always have this problem, just unplug the power and plug back in for both router and the modem, after that use the repair connection in winxp
uploadready_500mb said:
i always have this problem, just unplug the power and plug back in for both router and the modem, after that use the repair connection in winxp
The problem has been solved.
Read the whole topic before replying :wink2:
mine is set up on PPPoE and i have that problem every now and then, its most computer products needs to be rebooted every now and then.
worked fine for more then a year with absolutely no reset needed
now its acting up strange for the last 2 weeks. gotta reset everything every 3-4 days.

stupid technology heh
Now mines acting up. I'm blaming the Surfboard, since I can still access my network resources.
Sorry for bringing this topic back, but I am actually suffering from the same problem as the original poster did. I have though a WRV54G router (firmware version 2.39.2).

I did the same thing with renewing and releasing the DHCP and nothing happens. And I followed what was mentioned here, but I am still kind of stuck. I am not that computer literate and of course frustrated at this point. I at first called my ISP and he said that my router has been refusing their packets. I then found this site and followed with the notions of rebooting the router. I then enabled MAC clone and cloned back my original MAC address (I noticed it had changed under status of the router). And then reboot the router and the modem. I noticed that my router was no longer in an error state and my computer says I have internet connection....but I still cannot connect to the net.

So I am wondering if something is in conflict and I then noticed the local MAC address and that is it different from my MAC address. I don't know if they are suppose to match. All I know and please correct me if I am wrong that the MAC address of the router is the original address registered with the ISP and the local MAC address is the new address now assigned. I appreciate any help. Thanks!
I had the same problem and solved it by doing this

On the main setup page the ""Internet Connection Type"" should be
on ""Obtain IP Automatically - DHCP “. Click on the Save Settings
Now click on the sub tab ""MAC address clone"".
- Click on enable
Click Clone & click save settings
Check WAN Ip on Status page of router ....
If getting Valid Ip .... try going online
If not ... power cycle for 4-5 minutes & then agian check the WAN Ip address .....